当前位置:迪客赚 > 正文

功能“可为 null 的引用类型”在 C# 7.3 中不可用。请使用 8.0 或更高的语言版本

作者:迪客赚 发布时间:2022-08-22 14:32:39

功能“可为 null 的引用类型”在 C# 7.3 中不可用。请使用 8.0 或更高的语言版本。



然后我善用搜索,他们说点击报错的地方根据提示升级到8.0,但是我这里没有这个提示,所以我选择了第二种方法

找到后缀名为.csproj的文件



然后用记事本打开!我当时直接点,然后发现怎么一直是项目代码界面...然后才发现用要记事本(也可能是我的原因)



 然后在<PropertyGroup>里面添加<LangVersion>8.0</LangVersion> 


然后就解决啦!


  <PropertyGroup>

<LangVersion>8.0</LangVersion>

  </PropertyGroup>

有人说 <LangVersion>preview</LangVersion>这个也可以,但是我没试过啦


来源:(QQ/微信:313919848),转载请保留出处和链接!如有侵权或出处有误请联系网站客服,我们会第一时间为你处理。

本文链接: https://www.dikezhuan.com/post/91961.html

最新评论

欢迎您发表评论:

请登录之后再进行评论

登录
相关推荐
表情推荐
  • 这位同学我装逼的时候请你不要说话文字表情
  • 这位同学我装逼的时候请安静
  • 这位同学我装逼的时候请安静熊猫人
  • 这位同学我裝逼的时候请安静
  • 这位同学,我装逼的时候请安静!
  • 这位同志说的对
  • 这位同志请你不要搞黄色
  • 这位同志请你停车操你妈的
  • 这位基佬同志请控制下你的情绪公众场合禁止发骚
  • 这位基佬请自重
  • 这位基佬请自重
  • 这位大佬请醒醒您根本不是萌新